[TUTORIAL] Local KZTimer Server

Discussion in 'General Discussion' started by JWL, Oct 29, 2015.

  1. KStew

    KStew SCRUB

    Joined:
    Apr 1, 2017
    Messages:
    10
    Likes Received:
    12
    GameChaos likes this.
  2. KStew

    KStew SCRUB

    Joined:
    Apr 1, 2017
    Messages:
    10
    Likes Received:
    12
    I setup everything and it works just fine as far as I'm putting the map files (SomeMapName.bsp and SomeMapName.nav) directly into the "maps" folder.
    I tried setting up the workshop solution, so now I have a "wokshop" folder within my "maps" folder, containing about 360 files that are names something like "1560656354", each containing one .bsp and two .jpg's
    Also I added all the mapnames to the mapcycle.txt. Don't they still need .nav's?

    My problem is, that I can't fucking open all these maps with /sm_map SomeMapName and they also done show up in the /admin selectmap menu.

    I probably did something really stupid here, please help! :)
     
    GameChaos likes this.
  3. Sikari

    Sikari Yay for bugs! Staff Member KZGlobalAdmin Programmer

    Joined:
    Jul 31, 2016
    Messages:
    196
    Likes Received:
    326
    So are you using local mapfiles or workshop, im kinda confused. Also make sure your csgo/addons/sourcemod/configs/maplist.cfg has

    "default"
    {
    "target" "mapcyclefile"
    }
     
    GameChaos likes this.
  4. KStew

    KStew SCRUB

    Joined:
    Apr 1, 2017
    Messages:
    10
    Likes Received:
    12
    Well when im using workshop, the files end up getting downloaded, so they are local, too, aren't they? Well tbh I just copied my workshop folder from my real CS:GO into the server maps. I know thats not how it works, to get updated by itself, but I wanted to be able to play workshopmaps, so I thought I just copy em in and add them to the cycle txt and then I can load em on the server, but shit don't sem to work like that :(

    Yep it's there (maplistS.cfg). The maplist.cfg inside the csgo folder is empty tho.
     
    GameChaos likes this.
  5. Sikari

    Sikari Yay for bugs! Staff Member KZGlobalAdmin Programmer

    Joined:
    Jul 31, 2016
    Messages:
    196
    Likes Received:
    326

    I've never tried doing it like that, I would just recommend downloading them again from the server using host_workshop_collection
     
    GameChaos likes this.
  6. KStew

    KStew SCRUB

    Joined:
    Apr 1, 2017
    Messages:
    10
    Likes Received:
    12
    well I tried putting host_workshop_collection 897415592, which is collection #4, into the steamCMD GUI commandline, but that didnt work. Is this even where I'm supposed to put it?
     
    GameChaos likes this.
  7. DanZay

    DanZay PRO Staff Member KZGlobalAdmin Programmer

    Joined:
    Jun 2, 2015
    Messages:
    562
    Likes Received:
    1,489
    You can do it in the server console while it's running, too.
     
    GameChaos likes this.
  8. Sikari

    Sikari Yay for bugs! Staff Member KZGlobalAdmin Programmer

    Joined:
    Jul 31, 2016
    Messages:
    196
    Likes Received:
    326
    Like DanZay said, you can do it while the server is running.

    If you would like to watch the progress, you can do so by changing sv_debug_ugc_downloads to 1.

    Remember, theres 4 collections. If you want them all you have to download them collection by collection.
     
    GameChaos likes this.
  9. KStew

    KStew SCRUB

    Joined:
    Apr 1, 2017
    Messages:
    10
    Likes Received:
    12
    I have this in my autoexec:
    sv_setsteamaccount<nottellingyou>
    -authkey alsonottellingyou +host_workshop_collection 608046482 +workshop_start_map 576216273
    (I'm sure the keys are correct and mine)

    So why is the console telling me: "wep api auth key not found" when I'm trying to host the map collection?
    if i type "authkey alsonottellingyou" into the console it says unknown command.

    In which config file should I maybe put it instead?
     
    GameChaos likes this.
  10. DanZay

    DanZay PRO Staff Member KZGlobalAdmin Programmer

    Joined:
    Jun 2, 2015
    Messages:
    562
    Likes Received:
    1,489
    This goes into the commandline, not a config.

    sv_setsteamaccount will be fine in autoexec.cfg.
     
    GameChaos likes this.
  11. KStew

    KStew SCRUB

    Joined:
    Apr 1, 2017
    Messages:
    10
    Likes Received:
    12
    Okay, what worked for me now was just putting the -authkey in the comandline and then typing sv_debug_ugc_downloads 1 (optional) and host_workshop_collection 599549919 into console. Putting host_workshop_collection 599549919 into the commandline doesn't work for me for some reason.

    Collection 1 successfully installed and tested!

    Thank you so much guys! <3 (#nohomoheart) <3 <3 <3 <3 (#bunchaGayhearts in case ur gay xD)

    Well theres still some things left to figure out for me like how to use kztimer things, but ill have a go at these tomorrow.
    Thanks again :)
     
    Last edited: Oct 8, 2017
    GameChaos likes this.
  12. KStew

    KStew SCRUB

    Joined:
    Apr 1, 2017
    Messages:
    10
    Likes Received:
    12
    Okokokok. Now the freaking map changes every 3 minutes because there is an ingame timer of 3 minutes and i can't even open the cpmenu. How do I get it to load the configs properly? (Some stuff is loading tho, airstrafing works just fine fo example)
     
    GameChaos likes this.
  13. Ocelot

    Ocelot TRAINEE

    Joined:
    Dec 6, 2016
    Messages:
    46
    Likes Received:
    55
    you can change the time with mp_timelimit <time>
     
    GameChaos likes this.
  14. KStew

    KStew SCRUB

    Joined:
    Apr 1, 2017
    Messages:
    10
    Likes Received:
    12
    I reinstalled the KZ timer and now everything works like a charm :) must have deleted a file or something by mistake which might be possible sins i ehm priti stuhpit
     
    GameChaos and Ocelot like this.
  15. KStew

    KStew SCRUB

    Joined:
    Apr 1, 2017
    Messages:
    10
    Likes Received:
    12
    Okay one more thing.. My fucking console is getting spammed by some Out-of-range value inSendPropFLoat shit.
    https://gyazo.com/58406ec20fd96d4fc074fe8485fdf6d2
    I dont really care if that error happens, I just don't want it to appear in the console.
     
    GameChaos likes this.
  16. jony

    jony haHAA KZ Server Owner

    Joined:
    Sep 11, 2015
    Messages:
    100
    Likes Received:
    72
    i got that same error whenever i press "jump" and then my server starts freezing and crash after 5 seconds, i cant make any cleaner to work. rip
    edit:

    L 10/09/2017 - 19:11:26: SourceMod error session started
    L 10/09/2017 - 19:11:26: Info (map "workshop/245286254/bkz_goldbhop_csgo") (file "errors_20171009.log")
    L 10/09/2017 - 19:11:26: [SM] Exception reported: Stack leak detected: sp:38256 should be 38260!
     
    Last edited: Oct 9, 2017
    GameChaos likes this.

Share This Page